re = /^\*\sheadline(?:(?!^\*\sheadline).)*:END:$/m
str = '* headline 0
* headline 1
:PROPERTIES:
:KEY: lala
:END:
* headline 2
* headline 3
:PROPERTIES:
:KEY: lblb
:END:
* headline 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end