import re
regex = re.compile(r"^\*\sheadline(?:(?!^\*\sheadline).)*:END:$", flags=re.MULTILINE | re.DOTALL)
test_str = ("* headline 0\n"
"* headline 1\n"
" :PROPERTIES:\n"
" :KEY: lala\n"
" :END:\n"
"* headline 2\n"
"* headline 3\n"
" :PROPERTIES:\n"
" :KEY: lblb\n"
" :END:\n"
"* headline 4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")