using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\$\$)(?<group1>.+?)\1|\[(#)(?<group2>.+?)\3\]";
string input = @"$$My_Name$$
[#My_Name#]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}