$re = '/(\$\$)(?<group1>.+?)\1|\[(#)(?<group2>.+?)\3\]/';
$str = '$$My_Name$$
[#My_Name#]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);