re = /(\$\$)(?<group1>.+?)\1|\[(#)(?<group2>.+?)\3\]/
str = '$$My_Name$$
[#My_Name#]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end