package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w{7,18}$`)
var str = `Some16
Some127
Some127890123456_8
Some1278901234567_9
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}