$re = '/^\w{7,18}$/m';
$str = 'Some16
Some127
Some127890123456_8
Some1278901234567_9
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);