import re
regex = re.compile(r"^\w{7,18}$", flags=re.MULTILINE)
test_str = ("Some16\n"
"Some127\n"
"Some127890123456_8\n"
"Some1278901234567_9\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")