$re = '/^.*?\b(\S+@\S+)\b.*$/m';
$str = 'something@example.com
something.something@example.com
erase all this stuff something@example.com
ane all this stuff something.something@example.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);