// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?\b(\S+@\S+)\b.*$").unwrap();
let string = "something@example.com
something.something@example.com
erase all this stuff something@example.com
ane all this stuff something.something@example.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}