re = /^.*?\b(\S+@\S+)\b.*$/m
str = 'something@example.com
something.something@example.com
erase all this stuff something@example.com
ane all this stuff something.something@example.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end