import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:((?(3)\\s*|\\R*)->\\s*([\\w.]*(\\((?>'[^'\\\\]*(?:\\\\.[^'\\\\]*)*'|\"[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*\"|[^\"'()]++|(?3))*\\)))))+\\s*\\z";
final String string = "o.start_time = obj.s;\n"
+ "o.repair_type -> obj.r;\n"
+ "o.limit -> obj.l;\n"
+ "->god(\"('\\\"\\\"')\") ->fox(,'->')\n"
+ "->egg()->dog(,'c')\n"
+ " ->cat(,'b')-> banana(,'a\"\\'\\(\\)\\'->\"()(') -> apple(,'a')";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}