const regex = /(?:((?(3)\s*|\R*)->\s*([\w.]*(\((?>'[^'\\]*(?:\\.[^'\\]*)*'|"[^"\\]*(?:\\.[^"\\]*)*"|[^"'()]++|(?3))*\)))))+\s*\z/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:((?(3)\\s*|\\R*)->\\s*([\\w.]*(\\((?>\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'|"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|[^"\'()]++|(?3))*\\)))))+\\s*\\z', '')
const str = `o.start_time = obj.s;
o.repair_type -> obj.r;
o.limit -> obj.l;
->god("('\\"\\"')") ->fox(,'->')
->egg()->dog(,'c')
->cat(,'b')-> banana(,'a"\\'\\(\\)\\'->"()(') -> apple(,'a')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}