package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z][a-z']+(?: [A-Z][a-z]+)*`)
var str = `Obama told reporters in Washington that he and Netanyahu are opposed to Iran's calls for "Death To America"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}