re = /[A-Z][a-z']+(?: [A-Z][a-z]+)*/
str = 'Obama told reporters in Washington that he and Netanyahu are opposed to Iran\'s calls for "Death To America"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end