$re = '/[A-Z][a-z\']+(?: [A-Z][a-z]+)*/';
$str = 'Obama told reporters in Washington that he and Netanyahu are opposed to Iran\'s calls for "Death To America"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);