using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:\/\/|www\.)?[a-z0-9.-]+\.[a-z]{2,}";
string input = @"“+31 6 12345678 hhhhh ccccc aaaaaaa. bbbbbbbb (999,-) , weekschappen - en interm opdrachten - youtube duurzaam hoe dan www.ditiseenwebsite.com 5 - 10K schaalbaarheid - ik kan mezelf niet schalen. thisisalsoatest.nl hoe kan ik meer impact maken, minder tijd. 2 , ik gebruik het, maar zoekende , wat is er nog meer mogelijk? 7-10K https://test.eu Dit begrijp ik! Yes, gaan we regelen! test.nl”";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}