import re
regex = re.compile(r"(?:https?:\/\/|www\.)?[a-z0-9.-]+\.[a-z]{2,}", flags=re.MULTILINE)
test_str = "“+31 6 12345678 hhhhh ccccc aaaaaaa. bbbbbbbb (999,-) , weekschappen - en interm opdrachten - youtube duurzaam hoe dan www.ditiseenwebsite.com 5 - 10K schaalbaarheid - ik kan mezelf niet schalen. thisisalsoatest.nl hoe kan ik meer impact maken, minder tijd. 2 , ik gebruik het, maar zoekende , wat is er nog meer mogelijk? 7-10K https://test.eu Dit begrijp ik! Yes, gaan we regelen! test.nl”"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")