// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:https?:\/\/|www\.)?[a-z0-9.-]+\.[a-z]{2,}").unwrap();
let string = "“+31 6 12345678 hhhhh ccccc aaaaaaa. bbbbbbbb (999,-) , weekschappen - en interm opdrachten - youtube duurzaam hoe dan www.ditiseenwebsite.com 5 - 10K schaalbaarheid - ik kan mezelf niet schalen. thisisalsoatest.nl hoe kan ik meer impact maken, minder tijd. 2 , ik gebruik het, maar zoekende , wat is er nog meer mogelijk? 7-10K https://test.eu Dit begrijp ik! Yes, gaan we regelen! test.nl”";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}