using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\bABC \d+ )(?!.*\bABC\b).*";
string input = @"ABC anything about the sky ABC 123 and anything about the moon
ABC anything about the sky ABC and anything ABC 1 about the moon
ABC anything about the sky ABC and anything about the moon ABC 2 test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}