$re = '/(?<=\bABC \d+ )(?!.*\bABC\b).*/m';
$str = 'ABC anything about the sky ABC 123 and anything about the moon
ABC anything about the sky ABC and anything ABC 1 about the moon
ABC anything about the sky ABC and anything about the moon ABC 2 test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);