const regex = /(?<=\bABC \d+ )(?!.*\bABC\b).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\bABC \\d+ )(?!.*\\bABC\\b).*', 'gm')
const str = `ABC anything about the sky ABC 123 and anything about the moon
ABC anything about the sky ABC and anything ABC 1 about the moon
ABC anything about the sky ABC and anything about the moon ABC 2 test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}