re = /(\D)\./
str = 'FRAME WINDOW MASTER. 160.055-44.9 ADULT Z68.41
Hello.World'
subst = '\\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result