use strict;
my $str = 'FRAME WINDOW MASTER. 160.055-44.9 ADULT Z68.41
Hello.World';
my $regex = qr/(?<=\D)\.(?=\D)/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";