import Foundation
let pattern = #"(?<=\D)\.(?=\D)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
FRAME WINDOW MASTER. 160.055-44.9 ADULT Z68.41
Hello.World
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)