using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"abc (?:(?!mno)[\s\S])*(mno)?";
string input = @"abc mno
abc random mno unknowable
abc unknowable mno random
abc random def unknowable";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}