$re = '/abc (?:(?!mno)[\s\S])*(mno)?/m';
$str = 'abc mno
abc random mno unknowable
abc unknowable mno random
abc random def unknowable';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);