re = /abc (?:(?!mno)[\s\S])*(mno)?/m
str = 'abc mno
abc random mno unknowable
abc unknowable mno random
abc random def unknowable'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end