using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w\-][\w\-\.]+@[\w\-][\w\-\.]+[a-zA-Z]{1,4}";
string input = @"info@test.info
jobs@domain.be
rommel@romel.
test@test.be info@test.ru
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}