package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w\-][\w\-\.]+@[\w\-][\w\-\.]+[a-zA-Z]{1,4}`)
var str = `info@test.info
jobs@domain.be
rommel@romel.
test@test.be info@test.ru
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}