re = /[\w\-][\w\-\.]+@[\w\-][\w\-\.]+[a-zA-Z]{1,4}/m
str = 'info@test.info
jobs@domain.be
rommel@romel.
test@test.be info@test.ru
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end