$re = '/^(?!--).*(\{![^!]*!\})/m';
$str = '-- Here is some comment {!0-goal!}. Regex shouldn\'t match that!
{!1-goal!}
Here is some text and {!3-goal!} and some {!4-goal!}
It can be also as complicated as {!5-goal {!6-goal!} {!7-goal!}!}
Any thoughts?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);