import re
regex = re.compile(r"^(?!--).*(\{![^!]*!\})", flags=re.MULTILINE)
test_str = ("-- Here is some comment {!0-goal!}. Regex shouldn't match that!\n"
"{!1-goal!} \n"
"Here is some text and {!3-goal!} and some {!4-goal!}\n"
"It can be also as complicated as {!5-goal {!6-goal!} {!7-goal!}!}\n"
"Any thoughts?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")