#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(\{!(?:[^!]|\{![^!]*!\})*!\}))"
Local $sString = "{!1-goal!} " & @CRLF & _
"Here is some text and {!3-goal!} and some {!4-goal!}" & @CRLF & _
"It can be also as complicated as {!5-goal {!6-goal!} {!7-goal!}!}" & @CRLF & _
"Any thoughts?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")