import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(\\{!(?:[^!]|\\{![^!]*!\\})*!\\}))";
final String string = "{!1-goal!} \n"
+ "Here is some text and {!3-goal!} and some {!4-goal!}\n"
+ "It can be also as complicated as {!5-goal {!6-goal!} {!7-goal!}!}\n"
+ "Any thoughts?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}