re = /(?=(\{!(?:[^!]|\{![^!]*!\})*!\}))/m
str = '{!1-goal!}
Here is some text and {!3-goal!} and some {!4-goal!}
It can be also as complicated as {!5-goal {!6-goal!} {!7-goal!}!}
Any thoughts?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end