using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^S\w+(?=, [A-RT-Z])";
string input = @"Duncan, Jean
Schmidt, Paul
Sells, Simon
Martin, Jane
Smith, Peter
Stephens, Sheila
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}