re = /^S\w+(?=, [A-RT-Z])/m
str = 'Duncan, Jean
Schmidt, Paul
Sells, Simon
Martin, Jane
Smith, Peter
Stephens, Sheila
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end