import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^S\\w+(?=, [A-RT-Z])";
final String string = "Duncan, Jean\n"
+ "Schmidt, Paul\n"
+ "Sells, Simon\n"
+ "Martin, Jane\n"
+ "Smith, Peter\n"
+ "Stephens, Sheila\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}