#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "variable_[0-9]+"
Local $sString = "variable_9" & @CRLF & _
"variable_1" & @CRLF & _
"variable_0" & @CRLF & _
"variable_96"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")