using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"variable_[0-9]+";
string input = @"variable_9
variable_1
variable_0
variable_96";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}