$re = '/variable_[0-9]+/';
$str = 'variable_9
variable_1
variable_0
variable_96';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);