#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d"
Local $sString = "The rundown" & @CRLF & _
"The modern monitoring stack is increasingly diverse and complex. " & @CRLF & _
"Represented among the top 10 most popular tools are solutions for systems monitoring, APM, web and user monitoring, and log management." & @CRLF & _
"The top five monitoring challenges:" & @CRLF & _
"1) Quickly remediating service disruptions" & @CRLF & _
"2) Reducing alert noise" & @CRLF & _
"3) Securing budget for the proper tools" & @CRLF & _
"4) Quickly identifying service disruptions" & @CRLF & _
"5) Migrating services to the cloud" & @CRLF & _
"IT teams are feeling alert pain more than ever before." & @CRLF & _
"Almost half of those surveyed receive over 50 alerts per day from their tools, and about a quarter receive more than 100." & @CRLF & _
"Alert floods have a clear and substantial effect on remediation. " & @CRLF & _
"Of those who receive 100+ alerts per day, only 17% are able to investigate and remediate the majority (75-100%) within 24 hours." & @CRLF & _
"Strategic monitoring is clearly important, but execution is lacking." & @CRLF & _
"80% agree that strategic monitoring is important to their organization, but only 12% are very satisfied." & @CRLF & _
"A good monitoring strategy goes a long way." & @CRLF & _
"Respondents who are satisfied with their organization’s monitoring strategy find critical IT issues much easier to handle and report the best rates of remediation. In addition, organizations with a defined monitoring process are better equipped to respond to alerts." & @CRLF & _
"IT performance is increasingly tied to business performance." & @CRLF & _
"Customer satisfaction and SLA compliance take the lead as the most common KPIs to measure IT performance, outranking “traditional” metrics, such as MTTR and incident volume." & @CRLF & _
"Good news for budgets, but not for ROI." & @CRLF & _
"Only 16% anticipate a decrease to their overall IT budget in 2016, while a third expect it to increase. However, a dismal 9% agreed that they were very satisfied with their organization’s monitoring strategy, based on overall investment" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")