$re = '/\d/';
$str = 'The rundown
The modern monitoring stack is increasingly diverse and complex.
Represented among the top 10 most popular tools are solutions for systems monitoring, APM, web and user monitoring, and log management.
The top five monitoring challenges:
1) Quickly remediating service disruptions
2) Reducing alert noise
3) Securing budget for the proper tools
4) Quickly identifying service disruptions
5) Migrating services to the cloud
IT teams are feeling alert pain more than ever before.
Almost half of those surveyed receive over 50 alerts per day from their tools, and about a quarter receive more than 100.
Alert floods have a clear and substantial effect on remediation.
Of those who receive 100+ alerts per day, only 17% are able to investigate and remediate the majority (75-100%) within 24 hours.
Strategic monitoring is clearly important, but execution is lacking.
80% agree that strategic monitoring is important to their organization, but only 12% are very satisfied.
A good monitoring strategy goes a long way.
Respondents who are satisfied with their organization’s monitoring strategy find critical IT issues much easier to handle and report the best rates of remediation. In addition, organizations with a defined monitoring process are better equipped to respond to alerts.
IT performance is increasingly tied to business performance.
Customer satisfaction and SLA compliance take the lead as the most common KPIs to measure IT performance, outranking “traditional” metrics, such as MTTR and incident volume.
Good news for budgets, but not for ROI.
Only 16% anticipate a decrease to their overall IT budget in 2016, while a third expect it to increase. However, a dismal 9% agreed that they were very satisfied with their organization’s monitoring strategy, based on overall investment
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);