import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d";
final String string = "The rundown\n"
+ "The modern monitoring stack is increasingly diverse and complex. \n"
+ "Represented among the top 10 most popular tools are solutions for systems monitoring, APM, web and user monitoring, and log management.\n"
+ "The top five monitoring challenges:\n"
+ "1) Quickly remediating service disruptions\n"
+ "2) Reducing alert noise\n"
+ "3) Securing budget for the proper tools\n"
+ "4) Quickly identifying service disruptions\n"
+ "5) Migrating services to the cloud\n"
+ "IT teams are feeling alert pain more than ever before.\n"
+ "Almost half of those surveyed receive over 50 alerts per day from their tools, and about a quarter receive more than 100.\n"
+ "Alert floods have a clear and substantial effect on remediation. \n"
+ "Of those who receive 100+ alerts per day, only 17% are able to investigate and remediate the majority (75-100%) within 24 hours.\n"
+ "Strategic monitoring is clearly important, but execution is lacking.\n"
+ "80% agree that strategic monitoring is important to their organization, but only 12% are very satisfied.\n"
+ "A good monitoring strategy goes a long way.\n"
+ "Respondents who are satisfied with their organization’s monitoring strategy find critical IT issues much easier to handle and report the best rates of remediation. In addition, organizations with a defined monitoring process are better equipped to respond to alerts.\n"
+ "IT performance is increasingly tied to business performance.\n"
+ "Customer satisfaction and SLA compliance take the lead as the most common KPIs to measure IT performance, outranking “traditional” metrics, such as MTTR and incident volume.\n"
+ "Good news for budgets, but not for ROI.\n"
+ "Only 16% anticipate a decrease to their overall IT budget in 2016, while a third expect it to increase. However, a dismal 9% agreed that they were very satisfied with their organization’s monitoring strategy, based on overall investment\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}