# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=:keyword_start:).*?(?=:keyword_end:)//g;t' <<< "This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: This is also multiple space but this won't be replaced :keyword_start: this is the second content with double spaces :keyword_end: ... more text"