const regex = /(?<=:keyword_start:).*?(?=:keyword_end:)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=:keyword_start:).*?(?=:keyword_end:)', 'g')
const str = `This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: This is also multiple space but this won't be replaced :keyword_start: this is the second content with double spaces :keyword_end: ... more text`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);