const regex = /\d(?!(\d* times|\d*th|\d* hours|\d* substitutions))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d(?!(\\d* times|\\d*th|\\d* hours|\\d* substitutions))', 'g')
const str = `I have called 2 times on the 6th and 7th, and the order is 12 hours overdue please refund my credit card 1234-4567-7894-3214`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}