re = /\d(?!(\d* times|\d*th|\d* hours|\d* substitutions))/
str = 'I have called 2 times on the 6th and 7th, and the order is 12 hours overdue please refund my credit card 1234-4567-7894-3214'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end