$re = '/\d(?!(\d* times|\d*th|\d* hours|\d* substitutions))/';
$str = 'I have called 2 times on the 6th and 7th, and the order is 12 hours overdue please refund my credit card 1234-4567-7894-3214';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);